Jump to content
maverik

Thinking of getting gaming monitor - advice needed

Recommended Posts

1 hour ago, island55 said:

thats what i got and im not sure whats causing my lag or whatever i have going on but it could be the video card?

Multi-threading turned off?

Triple buffering turned off?

what version drivers ?

Remove the drivers with DDU app (display driver uninstaller), select the remove drivers via safe mode option. Then once the drivers are removed download the latest STABLE NON BETA drivers from Nvidia. 

DDU app: 
http://www.guru3d.com/files-details/display-driver-uninstaller-download.html
Nvidia GPU drivers: http://www.nvidia.com/Download/index.aspx

Also...

xbox mode off in win10, game mode off? 

You probably have tried all these but I figured I would throw them out there.

Also what are your GPU temps?

Does the stuttering happen in only fullscreen? Does it happen in windowed mode?

Try this yet?

http://westechsolutions.net/sites/WindowedBorderlessGaming/home

Good link for info... https://developer.nvidia.com/sites/default/files/akamai/gameworks/CN/Stuttering_Analysis_EN.pdf

Share this post


Link to post
Share on other sites

Nice find blud! That's a good deal on what seems to be a great monitor. 2k, 1ms, 144hz, IPS, 3 year warranty. How did it not come up during my research?

Problem is though, I send mine in for a replacement not a refund. So unless they tell me their out and I have to buy another model, I'm getting the same thing. Mind you I'd be happy to get the same model because I thought it was perfect (aside from the defect).

 

Share this post


Link to post
Share on other sites

What I like about Nvidia cards is that they are more energy efficient but I much prefer AMD's approach with Freesync compared to what Nvidia did with gsync. Plus if I buy an AMD card, I could run freesync off it. In the end though, I'm not religious about nvidia or AMD. Whatever works will do it for me.

Do you think that the RX580 could run 2k@144hz for ql? It's hard to find benchmarks for ql, that's why I'm asking here.

Share this post


Link to post
Share on other sites

Boost, that's what I used to think, but it's not the case. If you can maintain FPS > refresh rate, Freesync isn't needed or even useful. Of course when playing more demanding games than ql, freesync is very useful.

Share this post


Link to post
Share on other sites
1 hour ago, maverik said:

 

Do you think that the RX580 could run 2k@144hz for ql? It's hard to find benchmarks for ql, that's why I'm asking here.

I have an RX 470 4gb, and no problem with 250fps @144hz on 90% of ql maps, but my monitor is only 1080p. quakelive is a weird game, not sure why, but my pc can run Overwartch (newest game I have) on mostly medium to high settings at 1080p and maintain well over 100fps, but in quakelive on certain maps I still drop fps, although I've seen others with much better gpu's complaining about the same thing in ql. Maybe cpu is also factoring into ql and not as much in the newer games, idk. I was just showing you the rx 580 cause you were asking about the gtx 1050, and imo the rx580 at $185 is better bang for you buck than the 1050ti. For $50 more than that rx580 you can prob get a gtx1060 6gb...but on some benchmarks I looked at, the rx580 was about the same as the 1060, of course no benchmarks for quakelive, only dinosaurs play quakelive.

Share this post


Link to post
Share on other sites

That is weird. My old GTX560 (talking about dinosaurs) can also reach 250 fps on quite a few maps also in 1080p. But like you said not all the time - when shit starts flying it can sometimes take a hit in fps.

RX580 makes sense at this point. I'm going to wait to get my screen before committing to a card - by then I may also wait for Black Friday.

Share this post


Link to post
Share on other sites
14 hours ago, island55 said:

whatever you do do not get this;

https://www.amazon.com/EVGA-GeForce-Support-Graphics-04G-P4-6253-KR/dp/B01MF7EQJZ/ref=sr_1_1?ie=UTF8&qid=1539955657&sr=8-1&keywords=geforce+1050+ti+sc

 

thats what i got and im not sure whats causing my lag or whatever i have going on but it could be the video card?

That is the same card i have. It works flawlessly. Your issue is something else.

 

Edit* Mine isnt the super clocked one. It's this one.. but i doubt it's your card. i slam 250fps on all maps using this with an i5@3.4ghz 8g ram win 10. drivers are 397.64 I dont use the nvida software  to update drivers. ever. this build is super stable so i stay on it.

vid card.jpg

Share this post


Link to post
Share on other sites

i think it has something to do with data loss or something, i upgraded my cable wire from like cat5 to cat6 and got a shorter cable.. like i explained it to another guy i know and he thinks its some kind of loss/lack of retrieving data. cause the map is fine its just things take a second longer than they should to appear for me. like when i turn a corner on a map i dont instantly see enemies.. its almost like they spawn in .5 seconds later

Share this post


Link to post
Share on other sites

I don't agree. the cable wont matter unless it was bad. I think maybe your pc is doing something like 100% cpu or disk usage more likely. open the task manager while in game and look.

Share this post


Link to post
Share on other sites
21 hours ago, D347h said:

I don't agree. the cable wont matter unless it was bad. I think maybe your pc is doing something like 100% cpu or disk usage more likely. open the task manager while in game and look.

Good ole viterbi encoding will save the day in that regard. When crosstalk or other interference gets bad enough, the results tend to be much more pronounced than Island's POS 486 computer issues. :D

Share this post


Link to post
Share on other sites

so i updated my network drivers which i didnt know was a thing.. i pulled out an old 120gb ssd from like 2014 and did a fresh install of windows 7 and noticed i had no internet connection then realized i had to use the mobo cd to install drivers. my mobo cd installed intel network driver version 15.x - so i get on the intel site and realize version 23.x is available, no idea if this will help but im currently downloading ql on fresh wipe win7 install for testing

 

windows 10 intel network drivers:
https://downloadcenter.intel.com/download/25016/Intel-Network-Adapter-Driver-for-Windows-10

windows 7 intel network drivers:
https://downloadcenter.intel.com/download/18713/Intel-Network-Adapter-Driver-for-Windows-7-

Share this post


Link to post
Share on other sites

you were still using XP on a 486? dang. you should probably try Vista before you take the full leap to Win 7.. ease into it. ;)

Share this post


Link to post
Share on other sites

island your issue started when u upgraded monitor and went to 144hz? or u were at 144hz before. I can't remember exactly what happened to me, it was 2-3yrs ago so i dont remember it all clearly, but when i upgraded my monitor to 144hz, I ended up upgrading vid card first,then hd to ssd,then mb and cpu, and ram. I wasn't having issues in quake, but I was having something that sounds similar to you but in Overwatch. I think it was the cpu bottlenecking the video card. Maybe its your cpu bottlenecking your video card, have u tried to play in 60hz vs 144hz and does it still do  it?

 

so I basically upgraded my entire system to have Overwatch run smooth at 100+fps and I haven't played it in well over a year and don't even have it installed :) haha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×